BS woes and troubles

Moderator: Carlson Support

BS woes and troubles

Postby cujo » Sun Nov 16, 2008 7:16 am

MO,AD0,UN2,SF1.00000000,EC0,EO0.0,AU0
--SurvCE Version 2.07
--CRD: Numeric
--CA 5 NAD83
--Equipment: Leica Robotic Total Station
--TS Scale: 1.00000000
--EDM Mode: Standard
SP,PN1,N 1000.0000,E 1000.0000,EL100.0000,--STA
--P.C. mm Applied: 4.4000
OC,OP1,N 1000.00000,E 1000.00000,EL100.000,--STA
LS,HI6.0000,HR5.0000
BK,OP1,BP2,BS0.0000,BC0.0000
--Backsight by Azimuth
BD,OP1,FP2,AR0.00000,ZE89.33000,SD41.959923,--BS
BR,OP1,FP2,AR180.00010,ZE270.27010,SD41.959923,--BS
--SS,OP1,FP2,AR0.00000,ZE89.32590,SD41.959923,--BS
--Calculated: AR0°00'00"
--Measured: AR0°00'00"
--Delta: AR0°00'00"
--Backsight Check: PT 2
BD,OP1,FP2,AR0.00000,ZE89.33000,SD41.959923,--x
BR,OP1,FP2,AR180.00010,ZE270.27010,SD41.959923,--x
--SS,OP1,FP2,AR0.00000,ZE89.32590,SD41.959923,--x
--Calculated: AR0°00'00", HD41.959, Z101.330
--Measured: AR0°00'03", HD41.957, Z101.323
--Delta: AR0°00'03", HD-0.001, Z-0.006
--Backsight Check: PT 2
BD,OP1,FP2,AR0.00000,ZE89.33000,SD41.959923,--x
BR,OP1,FP2,AR180.00010,ZE270.27010,SD41.959923,--x
--SS,OP1,FP2,AR0.00000,ZE89.32590,SD41.959923,--x
--Calculated: AR0°00'00", HD41.959, Z101.330
--Measured: AR0°00'03", HD41.957, Z101.323
--Delta: AR0°00'03", HD-0.001, Z-0.007
--Backsight Check: PT 2
BD,OP1,FP2,AR0.00000,ZE89.33000,SD41.959923,--x
BR,OP1,FP2,AR180.00010,ZE270.27010,SD41.959923,--x
--SS,OP1,FP2,AR0.00000,ZE89.32590,SD41.959923,--x
--Calculated: AR0°00'00", HD41.959, Z101.330
--Measured: AR340°43'02", HD30.524, Z99.781
--Delta: AR19°16'58", HD-11.435, Z-1.549
--Backsight Check: PT 2
BD,OP1,FP2,AR0.00000,ZE89.33000,SD41.959900,--x
BR,OP1,FP2,AR180.00010,ZE270.27010,SD41.959900,--x
--SS,OP1,FP2,AR0.00000,ZE89.32590,SD41.959923,--x
--Calculated: AR0°00'00", HD41.959, Z101.330
--Measured: AR359°59'53", HD41.958, Z101.332
--Delta: AR0°00'07", HD0.000, Z0.002
--Backsight Check: PT 2
BD,OP1,FP2,AR0.00000,ZE89.33000,SD41.959900,--x
BR,OP1,FP2,AR180.00010,ZE270.27010,SD41.959900,--x
--SS,OP1,FP2,AR0.00000,ZE89.32590,SD41.959923,--x
--Calculated: AR0°00'00", HD41.959, Z101.330
--Measured: AR359°59'47", HD41.958, Z101.332
--Delta: AR0°00'13", HD0.000, Z0.002


Just what is going on here? :?:

I set the gun up, established a BS (F1/F2), and then practiced checking my BS. Remarkably, no matter what reading I got, what was recorded in the raw file was my original BS readings. What really made that remarkable is that despite having the setting 'set' to take F1/F2 to backsights, when you do a BS Check instead of Set and Read, it doesn't bother with the F2 (another bug). So, F1 shot to the BS for the check, and yet parroting the F1 and F2 from earlier.

It doesn't end there ... below are two lines from the first BS check:
--Measured: AR0°00'03", HD41.957, Z101.323
--Delta: AR0°00'03", HD-0.001, Z-0.006

When you loook at the raw file in the field on the data colletor, the Measured AR is 0-00-30. Yes, 30". Now, on download it looks correct, but on the data collector it says 30". I think one a few shots later that said 02" it actually said 10" on the data collector nothing consistent.

You may notice about 3 checks down I purposefully pointed to a very false backsight to see what it would do. Still reported the same calm BD and BR reading to my raw file.

If you are using a raw file processor, and if you are doing some type of least squares adjustment, with SurvNET or StarNet for example, what are all these repeated false readings going to do to your adjustment? I can tell you already that StarNet considers this an incomplete set, as does the Xport raw file processor, but even if I dropped the BR manually be a remark note, those aren't true readings and large group of F1 only shots to my backsight is going to skew my vertical relationship between the points for the worse. Damn statistics.

But your honor, I paid for this software and it sure looked like it was working; who has time to check and make sure it really is? (the surveyors who buy it? the software developer?... :cry:
If the beta testers are being paid they ought to send back their checks. This is basic stuff, I haven't even gotten my gun set up and oriented without a handful of problems. What am I going to find out next?

I wasn't testing this yet (not even done with all the BS issues) but I think if you hit the Set key on the BS screen it merely sends the requested circle reading to the gun where it is sitting, without turning on the EDM. I could be wrong, but I thought the EDM had to fire for the gun to sense the center of the prism. Hopefully we all know that the gun does not actually turn to the center, just close enough to sense where it is and then sets the circle so that if you actually pointed at the center it would read 00 (or whatever was requested) If I have Leica robot with ATR on, then that key should say "Manual Set" or something so people know they have to go old school and look through the sight (like a on a natural or something). Back when TDS was on board they had that big bug (you had to set zero with the Leica software then go into TDS and tell it you had already done so). If you tried to use the only Set Zero option in TDS it never fired the EDM and you just got "close".

I'm going to keep v2.x long enough to test it out and point out every problem I can find (as time permits in this crappy economy) Then if these issues aren't addressed I'm going to reload 1.65, which despite its own bugs doesn't seem to want to see me in trouble. Too bad, I hear there are some really cool new features in the MAP mode. My reseller was right to make me wait this long to attempt the upgrade ... I thinking I should have waited longer.

I don't have the raw files for this yet, but we've been finding that after shooting sets, the data collector inserts incorrect HTs for the BS shot one might take after the set. Of course it reports everything correctly on the screen, just screws up what is supposed to be the record of the survey and what you might use to make an adjustment of yoru field work.
Take care,

Rich
_________________________

Carlson Survey 2010 Standalone
Allegro CX SurvCE 2.5
Leica 1203 Robots
Leica DNA Level
Sokkia SDL Levels
cujo
 
Posts: 69
Joined: Thu Oct 23, 2008 2:01 am
Location: Southern California

Posting while frustrated...

Postby cujo » Thu Nov 20, 2008 4:54 am

OK, I'm sure there is a sense I've posted while under frustration recently: Guilty

I want SurvCE v2 to be the best data collection package. I want it to work with the gear and software I already have, maybe even the procedures I've had in place.

I'm invested for a small firm: 8 seats of Carlson Survey, 3 Allegro's with SurvCE. I'm looking to in the future add Altus GPS units, and currently the best or only practical solution for DC is Carlson. As much as anyone I really want it to work. Not only in this depressed market, but in the interest of not learning something new, I want to continue to expand SurvCE and Carlson into my business. My levels, my gps, everything, one solution, Carlson. I'm even starting to work with my friends to see if SurvNet can do all we rely on StarNET for currently.

I'm not 'bitching' to bitch, I want it fixed, I want to help, whatever!

There, I got that off my chest, cleared the water, and will post with a renewed attitude and vigor. :wink:
Take care,

Rich
_________________________

Carlson Survey 2010 Standalone
Allegro CX SurvCE 2.5
Leica 1203 Robots
Leica DNA Level
Sokkia SDL Levels
cujo
 
Posts: 69
Joined: Thu Oct 23, 2008 2:01 am
Location: Southern California

Postby AUSTIN » Mon Dec 01, 2008 1:12 am

Hi Rich,

Thanks for the detailed reports.

Unfortunately if you scroll through the threads you'll find VERY little in the way of feedback and responses to some very important issues.

After sending detailed reports on similar (and other non BS) issues and directly to Carlson from 2007 - April 2008, I was frustrated with the lack of feedback and action.
I tried posting a few harsh threads here in an attempt to shame Carlson into action - to no avail.

Yes, you're right - the beta-testers should send their pay cheques back.

Oh, hang on a minute - it seems WE are the beta-testers ! :roll:

I reported similar issues (and many other non BS bugs) direct to Carlson and received a few promising responses but no action.

I've most recently been dealing direct with the Aussie support guy, and he seems to get more action happening from the US, so I'm starting to see some better results.

Apparently 2.08 is imminent, but don't hold your breath for the release notes :roll:
AUSTIN
 
Posts: 7
Joined: Mon Aug 04, 2008 1:25 am
Location: Perth, Western Australia


Return to SurvCE General

Who is online

Users browsing this forum: Bing [Bot], Google [Bot]